Tuesday, 7 July 2015

E60: New Engine Tune Up Part 5 - Injectors / Smooth Running Control

The car is running OK, but the lumpy idling is still annoying me. Others don't notice it and I should probably just throw the acoustic-covers back on and just enjoy the car, but the urge to investigate the smooth-running control issue [this post] was just too great and a big job has broken out yet again.

I repeated the smooth-running measurement and injector 5 was still giving zero reading, so I bought a re-conditioned one off eBay for £45. I had also noticed oil running down the centre of the rocker-cover that seemed to be leaking out from the rear injector ports, so my logic was if they were coming out for cleaning and re-seating I may as well replace no. 5 and not worry about having to do the work again if it was indeed faulty. Saturday's jobs are listed below:
  • Replaced injector 5.
  • Removed / cleaned injectors.
  • Refitted rocker-cover and injectors carefully!
  • Repaired sheathing of inj. 5 ground wire.
  • Cleaned MAP sensor.
  • Put swirl-flap actuator back on vac-line.
  • Made sure inj. leak-off hose is secure! [It popped off while working on it, lost £5 fuel at least.]

BEGINNING DIESEL INJECTOR CODING:

In the days leading up to the work above I was contacted by another user who had the same issue with the smooth-running readout. They had fitted a brand new injector to the cylinder showing zero and it had made no difference to the readout. I hoped mine would not turn out the same way and the new injector would cure the problem, but it did not. A crushing final smooth-running measurement still showed 0.0 for injector 5 and the idling remains the same. My contact feared a fried ECU / DDE and had theirs tested, but it came back with no faults. This is unlikely anyway if the car is running OK and it turned out to be a software problem with the scanner. Later using INPA on my laptop I was able to view correctional-amounts for all 6 cylinders, so no. 5 was likely never a serious problem. Better yet, the amounts shown for mg/stroke were more realistic and not 100mg out like before. Never the less, the poor idle remained.


I was now informed that if an injector had been replaced then it would need coding. Basically, every injector has a slightly different correctional-value and is given a unique code. These are stored by the ECU after assembly, which then operates each injector perfectly within the parameters set by each code. When a new injector is fitted the ECU needs to be recoded accordingly. The codes are found in the lower-left quarter of the markings on top of the injector, shown in the photos. M57NTU BMWs used Euro 3 v2 injectors in 2003 and from mid-2004 used Euro 4 injectors. These are interchangeable, even late E39 units work, but injectors made after 2007 for the later M57NTU2 do not. A great guide on BMW diesel injector codes is here - http://www.bmw-planet.com/diagrams/release/en/zinfo/FIN0201FB47TU033.htm.

As each cylinder is coded to a specific injector the order the injectors are fitted in is critical and must remain the same. This got me wondering if that could be the cause of the lumpy tickover after all. During the whole course of the swirl-flap repair and then engine swap these same injectors have been removed from the head half a dozen times. It is possible that during nozzle-cleaning or engine-swap teething troubles that one or two may have become jumbled. The only way to know is to read the code sequence on the ECU and match them to the codes on the injectors, so I fired up the scanner and went into Injector Programming. What I found was the picture below. Only 1-4 showed up with codes and only the first one matches any of my injectors. No. 5 and 6 are blank, but only 1 and 2 can be selected to alter the code anyway, so it would seem that the scanner I am using is unsuitable for complex BMW work - it is, after all, optimised for Transit vans. I have now procured some dedicated diagnostic software and a BMCables.com blue OBD-USB cable, which will hopefully give an improved result like it did with the smooth-running readout. If the codes still don't match my injectors then they're not the originals and were never coded in anyway, putting the idle problem into a different court entirely. Only time will tell, as INPA does not work for injector-coding on diesel Beemers - for that you need DIS and it has been so hard to set up that I will have to cover it in later posts.

My current injector codes are:

1 - 7G1R6A [Euro 3 v2]
2 - ASR1CE [Euro 3 v2]
3 - 6RH1DW [Euro 3 v2]
4 - BZZNBI [Euro 3 v2]
5 - 7GZ6417 [Euro 4]
6 - B1APEI [Euro 3 v2]

No comments:

Post a Comment