Friday, 24 October 2014

E60: Split Vac-line, some boost, weird noises.

The turbo whine and lack of boost has persisted, so I took off the inlet-manifold again to check the vacuum-lines and found one has snapped off. Luckily, there was plenty of hose left to cut it down and push it back onto the T-piece. I re-checked every line twice against the diagrams on RealOEM.com and refitted the manifold, making sure the seals were super flush. Now when I fired up the turbo started making a ridiculous whoosh and dump-valve style hiss, as in the vid below. Some boost had returned too, though not as much as there should be and certainly nothing like the turbo sounded. Still, the vac-line repair did get a result, so it looks there could be life in the turbo yet.


There was nothing else I could do other than pore over the vac-line configuration, so I made this quick one-piece diagram to show the route of the four coming off the servo-pipe to save switching between several diagrams on RealOEM. I then started pulling vac-lines off in order to find the faulty area and, amazingly, managed to get rid of the whoosh/hiss and still have some boost. The turbo is still whistling though and there is not enough pull as you get over 2k rpm, so something is still amiss.

  • Split vac-line to swirl-flaps - Low boost, quiet turbo-whistle higher up.
  • Repaired vac-line - Some boost low down, cuts out higher up. Loud whoosh and hiss noise, turbo-whistle constantly.
  • Vac-hose removed from wastegate - Low boost, quiet turbo-whistle higher up.
  • Swirl-flaps and engine-mount vac-lines switched round - Some boost, no whoosh/hiss, constant turbo whistle, less engine vibration.
The diagrams do not make clear the route of the red/black striped hose on the right of mine. This turned out to be the N/S engine-mount and another scan of RealOEM.com revealed how they work in the pic below. I had wondered about a problem with the engine-mounts anyway, as there seems to be a lot more engine vibration than before, especially on tickover, so my next job will be to find the pipes that link the mounts together and check their condition. They all run through the subframe next to the steering-rack. M57N is a complicated vacuum arrangement.

Wednesday, 15 October 2014

E60: Opening Stuck Bonnet.

PROBLEM:
The annoying turbo whine from my previous post can only be heard while underway and not while stationary, so the bonnet is up and down for every bit of work and test drive. After several such runs, the O/S (driver's side) bonnet latch refused to open. Nearly an hour was spent with a helper pulling the bonnet-lever while I tried to push / pull / wiggle the O/S bonnet up, but it was stuck solid. The front bonnet lip on the E60 (and all modern BMWs) extends right down over the slam-panel / grille and the latches are a good 6 inches up inside it. It's impossible to slide something up through the gap between the rubber seal and pop the latch from outside, as you can with older cars, so I turned to the internet and eventually found a superb solution.

CAUSE:
Yes, this is quite a common problem with the E60, especially when you are working on it at home. The cable splits in two and a separate one runs to each latch. The end of the cable fits through an eyelet on the 'release-switch' and is kept under tension by a plastic collar that fits into a notch in the latch-frame. If the plastic collar pops out of the notch, cable tension is lost and the bonnet-lever simply will not pull the release-switch far enough. Removing the bonnet-lever reveals a plastic-cage with the cable housed deep inside, so yanking that further with a pair of grips won't do either. If you've been working on the front-end of the car and changed the location of the bonnet-latches / slam-panel, even slightly, then there's a high chance the collar will start popping out.

SOLUTION:
There are a few forum threads saying the latch can easily be opened from underneath the car, with the front under-tray removed. This is true, but the E60 engine-bay is so tightly packed there is a bit more to it than that. I have to give props to Kilty1 on forum.BMW5.co.uk, for his amazing guide, linked below:

http://forum.bmw5.co.uk/topic/87159-bonnet-release-not-working/

Getting to the latch requires removal on the front under-tray, both pieces of the O/S brake air-duct and the plastic inlet-pipe that runs to the air-filter. These can all be removed from underneath the car, as shown in Kilty1's guide. He used ramps, though I managed to open mine with the car raised a few inches on an axle-stand. Looking up with a torch, you will just see the latch next to the inner corner of the headlight.

Luckily, my brake duct, inlet pipe and tray were already off as I was working on the car, so I could get straight to the latch and will just show a couple of steps and pics from Kilty1's guide:

1. Reach up and slide a steel-rule or similar slim/flat object into the bottom of the latch, just to the inside of the right-hand spring-wheel [shown on the left in the pic, looking from front]. When the steel-rule is far enough in there should be a small clunk. Now slide the steel-rule quickly out and the bonnet latch should release on the O/S. 
2. The collar doesn't take much to pop out, so to stop it from happening again as soon as you shut the bonnet, wrap a cable-tie round the back of the collar and round through the gap in the steel-frame. It will be solid.

Tuesday, 14 October 2014

E60: Turbo whine and no boost!

With the engine-swap teething problems put to rest and the car back on the road [at last!], there was bound to be a few running faults. All in all its going like a dream, though I would say the engine is a lot noisier and vibrates more than before. This could mainly be due to the lack of acoustic-covers and under-trays as I iron out defects, but not entirely so I will have to look at the pneumatic engine-mounts when I have time.

When I got the car out for a good run, the main problem I notice is a serious lack of boost. The turbo is also making a low-pitch whining noise, which sounds a bit like a police siren. I read that this is the noise of a dying turbo, though I find this a little hard to swallow as it was fine before and I see no reason how being removed from the car for 3 weeks would affect it. Far more likely that I've messed up attaching some vac-line or wire-connector, or lets hope so anyway. It's an annoying whistle, as it can only be heard while driving under load and not when revving at a stop.
  • Turbo can be seen spinning.
  • No front-rear play on spindle-shaft, hardly any left-right play.
  • Pipes from turbo to intercooler and intercooler to inlet OK.
  • Removed and cleaned air-temp. sensor.
  • Some boost air is coming from the intercooler outlet.
Before I diagnose a dead turbo and start spending any more money, I will check the vacuum lines meticulously and also re-check the pipes for splits. The turbo also needs looking at, from the oil-feed to how it's fitting the manifold. The waste-gate doesn't seem to be operating and that seems a bit too serious to be caused by such a small vac-line fault. Ho hum, the saga continues...

Monday, 13 October 2014

E60: PAS-Pump + Exhaust Vibration-Damper.

With everything else apparently working, the 530d was still of the road due to the niggling problem of an un-bleedable PAS-system and rattling exhaust.
  • Bleed PAS-system with cap off reservoir and engine off, by turning the wheel lock to lock about 30 times and adding fluid until no more bubbles were coming out.
  • Remove front-bumper and drive back onto ramps.
  • Locate exhaust onto connecting-rods of vibration-damper.
  • Modify connecting-rods to fit new exhaust position.
  • Refit exhaust and reinforcement-plate.
  • Refit engine centre-undertray.
  • Drive off ramps, refit bumper and test drive!
PAS-Pump Bleed:
This is the hardest to bleed PAS-system I have ever come across, though the pipes / pump have been off the car for 3 weeks and could have allowed the system to drain and fill with air more than before. The pump was whining on tickover and making an almighty groan when turned in either direction. The fluid in the reservoir was also frothy white. To fully bleed it required the engine and reservoir cap to be off and the wheel turned full lock left to right about 30 times. To do this I raised the front of the car on axle-stands so the wheels were still touching, but with hardly any weight on them. The first turns lock to lock gulped the remaining fluid right into the system and so much air was coming out I kept re-checking the pipes for a leak. Eventually, the reservoir had swallowed the last of my bottle of fluid and is just about sitting up to the minimum mark, but still bubbles were popping up as the wheel was turned. The lock to lock business continued with me and my dad taking turns for quite some time until there were finally hardly any tiny bubbles rising to the surface. This whole thing was a job in itself, but the pump is very quiet now and the steering assistance is back.

Exhaust Vibration-Damper:
During the first tests there was an almighty rattle from the exhaust from tickover up to about 2k rpm. I assumed this to be because I had left off the exhaust 'vibration-dampers' that brace the bottom of the cat to the gearbox and stop it shaking. I discarded replacing it at first as, if you don't remember exactly the way it all fits together and start bolting your gearbox and exhaust back on willy nilly, then it's impossible to figure out. The long bracket with 3 holes fits around the edge of the gearbox bell-housing, held in by one of the large E14 and two of the smaller E10 Torx-bolts that hold the box to the engine. The connecting-rods then run from the foremost stud on the cat to the N/S stud on the bracket; and from the rearmost stud on the cat to the O/S stud on the bracket, as shown in the picture from TIS. Only trouble was, neither of the rods went anywhere near the brackets. I'm not sure if the entire engine and gearbox is in a slightly different position from before, or it's just the exhaust out of line, or both, but the eyelets on the left-right rod were about 5mm too long for the studs; and the front-rear ones were almost an inch too short. After 2 frustrating hours spent removing mounts and trying to relocate the gearbox / bracket to meet the exhaust I gave up and decided to modify the connecting-rods to fit the new gap lengths. The only remaining way to adjust exhaust position would be to loosen the two nuts holding the cat to the back of the turbo, only to do this requires the rocker-cover / injectors to come back off and I'm not doing that, for now at least.
The modified connecting-rods are below and, due to lack of time, are rather crudely done. I bent the left-right rod down about 3/4" at a steep angle to take 5mm length out of it and help bring it down to the bracket at a flush angle and works rather well. The front-rear was a bit less neatly done and makes use of a piece of 1mm sheet-steel, cut roughly to an inch square and bolted to the rod. It's not the best workaround in the world, but it gets the job done.
After all that, the 'vibration-damper' did not get rid of the rattle! Instead, I traced the annoying noise to the front rubber-mount a bit further down the pipe. The exhaust was banging right into the side of the metal bracket on the gearbox-mount and a bit of fiddling with the adjustable eyelet managed to separate them and killed the rattle dead, so there you go.


Saturday, 11 October 2014

E60: New Engine finally running!

Changed the injector seals last Sunday and gave the ports another good clean. The mist has stopped, but it still did not want to fire. There is fuel to the injectors and the timing is spot on, so this could only mean 2 things - something electronic isn't working properly, or the entire DDE module has fallen out of sync with the engine...

I don't even want to know what the latter option entails, so carried on swapping sensors on the new engine for those that worked on my old one. I found the crank-sensor was completely covered in dirty oil, in fact the whole slot was filled with it. Engine sensors are funny things and I can see how the oil could stop it from seeing the notch on the flywheel, but it doesn't explain why the engine would not turn over well using a can of Easy-Start. Either way, with the crank-sensor from my original lump in place it fired up straight away! Result.

[Video is with EGR-pipe disconnected and no air-filter / muffler fitted.]


  • PAS-pump sounds like it's dying - extreme whine / groan when the wheel is turned - and is now the only thing keeping her off the road. Will try bleeding tomorrow and maybe fresh fluid, but failing that the pump could have packed in or, worse, I've damaged some of the piping / rack while lifting the engine in.
  • Rear rubber exhaust-hanger missing. TIS says to remove the screws holding the hanger-bracket, not remove the rubber. I cut mine off to hastily get the exhaust down and will have to buy and annoyingly fit a new one.
  • Front exhaust vibration-damper simply will not fit. When fitted to the exhaust, the eyelets on the two connecting-rods are way off the studs on the gearbox-bracket. The left-right rod is only about 5mm out, but the front-rear rod is miles off. I will have to remove the rear and centre brackets and try to relocate the exhaust a bit.
Other than that, no iDrive messages, no engine-management light, no 'Increased Emissions', no leaks, no mist and no funny noises. The gearbox and clutch are working fine and the car is desperate to be driven. Curse that power-steering fault!

Wednesday, 8 October 2014

E36 Compact: M43 Oil Change + Filter Removal.

Got round to changing the oil and filter on the Compact, as I've been running it for a month with the mayonnaise filled concoction left from the dodgy head-gasket / cooling issue.

Removing Oil-Filter:
The filter-housing on the later M43 316i / 318i is right down in the bowels of the engine and impossible to get to easily, as they are on almost all other BMWs. The lid has no nut either to undo it from above, so the only way is to use an old-skool oil-filter removal tool from the side, only most of the engine prevents this.

The simplest way to get it off is to remove the fan-cowl and fan. This way there is just about enough room at the front of the engine to get a turn on the filter with the removal tool. I found a chain based removal tool works well, but a steel-belt one would probably be just as good. It isn't essential, but I removed the top inlet-manifold too, just to see what I was doing more clearly.

1. Remove the fan-cowl by undoing the two top screws with a 10mm socket and lifting it off, popping it out from the air-inlet ducts at either side.

2. Remove the two 8mm screws holding either side of the rear edge of the fan-housing at the top and lift the fan vertically up, sliding it out of the two bottom lugs.

3. Slide the removal-tool in from the front and there should now be room enough to get a turn on the filter-housing lid, even if it's as tight on as mine was.

E60: Engine Swap Week - Day 7

  • Remove inlet-manifold, rail, injectors and rocker cover.
  • Improve fit of fuel-rail return pipe.
  • Clean injectors.
  • Clean out injector ports in head.
  • Fit original rocker-cover.
  • Adjust injectors to fit collars tightly.
  • Look for fuel in rail and rail-pressure when cranking.
The only thing I didn't do today was swap my crank-sensor over. I figured the automatic models have a different flywheel so would have a different sensor, but the two transmissions share the same sensor [exact same part no.] so the one that's on should work.

The banjo on the fuel-rail return hose needed refitting, as the jubilee-clip was now fouling the inlet-manifold. It was a bugger to find a way to refit it and give enough gap - the manifold is still fouling slightly.

I fitted my original rocker-cover because the new one has a crack round the MAF-sensor housing, obviously where the donor car had it's bump. The injector collars were fitting a bit loosely in the new rocker-cover too and are a bit tighter now. My original cam-sensor is back on too, which I doubt will make a difference, but can't hurt.
  • Re-attempt start!
NO! The engine is turning ok and there is fuel-pressure. Sadly, there is now a lot of diesel-mist shooting up past the injectors, as in the vid below. Ah well, nothing ever goes smoothly.

Saturday, 27 September 2014

E60: Engine Swap Week - Day 6

  • Replace snapped T-piece on injector leak-off pipes.
  • Torque up crank-pulley and HP-pump.
  • Refit drive-belts.
  • Refit radiators / coolers.
  • Refit headlights and crash bar.
  • Refit slam-panel and grilles / ducts.
  • Plumb cooling, A/C and PAS back in at the front.
  • Loosely refit exhaust and heat-shield.
  • Fill with oil and coolant.
  • Refit ECU and plug loom in.
  • Plug in all wire connectors to engine.
  • Refit fuel-rail and pipes.
  • Refit turbo and exhaust-manifold.
  • Refit rocker-cover and injectors.
  • Refit inlet-manifold.
  • Attempt start!
NOTE: Fasten engine-mount top nuts! Neaten up fuel-rail return pipe!

Well, sadly, it didn't fire right up in the first few tried like last time, but the battery has been sitting for a month and died quickly, so I will charge it overnight and have another crack tomorrow.
  • Check for missing wire-connectors. Crank-sensor?
  • Bleed injectors and check for rail pressure.
  • Flywheel position sensor - is it a different flywheel? Swap to original.
  • Check injector-leads for pulses with multimeter.
  • High-pressure pump - does it need bleeding? Is it working?
  • Is 'Service Due' warning affecting immobiliser?
If all these check out and it still won't go then I will have to get a computer on it and get some fault-codes. I'm back in work next week, without a break, so I should be able to bring the Launch home.

It's been a hella lot of work the last 6 days so it would have been nice to have the engine fire up on the third go like it did when I fitted the new cylinder head, but ah well, I'm full of optimism at the close of today.

Plastic T-piece nozzle snapped off in the injector leak-off hose. Luckily I got fuel pipes with the new engine [even though the pump itself was missing] and didn't have to buy a new one.
From an '03, to an '09 and now back to an '04 - this is the third head in the E60.

Friday, 26 September 2014

E60: Engine Swap Week - Day 5


  • Attempt to lift gearbox underneath car.
  • Lift engine back out.
  • Fit gearbox to engine.
  • Remove bonnet / A/C-duct.
  • Lift engine and gearbox in together [mm to spare!].
  • Fit prop-shaft.
  • Fit gearbox mounts.
  • Fit starter-motor.
  • Fit oil filter/cooler.
  • Fit alternator.
  • Fit PAS-pump.
  • Fit A/C compressor.
  • Fit thermostat.
  • Re-attach lower wiring-connectors.
  • Loosely fit crank-pulley.
  • Loosely attach main electric-cables to alt / starter.
  • Loosely fit anti roll-bar.
NOTE: remember sump wire connector + tighten 10mm screw on gearbox!


Gearbox was getting nowhere from below with so little room under the car, so the engine came back out and we lifted the gearbox on very easily.
By removing the plastic air-con duct at the back and popping the bonnet lifters off so it lifts up vertical, it is possible to just about lift the engine and gearbox in together without lowering the subframe / rack.
Just the rads and injectors now and it's pretty much ready to start.

Thursday, 25 September 2014

E60: Engine Swap Week - Day 4

Had a lost day yesterday when the engine didn't arrive. It only turned up at 1.30pm today, so I will have to concentrate on swapping over the high-pressure pump, flywheel and clutch, as well as removing the loom etc. ready to patch mine in. Lifting the engine in will have to wait until tomorrow.
  • Replace steering-rack / subframe bolts entirely.
  • Remove loom and vacuum-hoses from new engine.
  • Swap over high-pressure fuel-pump.
  • Fit flywheel and clutch.
  • Remove oil filter/cooler and rocker-cover for lifting.
  • Match engines entirely.
  • Lift engine in.
Engine arrived at 1.30pm.


And was finally sat in the bay at 7.30pm.

Wednesday, 24 September 2014

E36 Compact: E46 Driver's Arm-Rest Retrofit

Just as on E46, the two bolts holding the handbrake down hold the right side of the arm-rest bracket. The third threaded-hole is covered by putty a bit further down the left side of the trans-tunnel.
The three existing holes fit the E46 arm-rest bracket, longer 13mm bolts and shims perfectly.
The rear roll-down ash-tray trim screws to the rear of the arm-rest bracket.
The centre-console trim took a bit of getting in under the gearstick trim panel, but fits the rear and arm-rest pretty well.
As does the handbrake handle and leather gaiter. Just deciding now whether to retrofit the gearstick trim panel and window-switches from the E46, or cut the centre-console trim to fit the E36 better. Hmm.

Tuesday, 23 September 2014

E60: Engine Swap Week - Day 3

  • Drop prop-shaft.
  • Remove slave-cyl. / gearshift linkages.
  • Drop gearbox.
  • Lift engine out.
  • Remove parts for new engine.
Once the prop was down it didn't take long at all to get the engine out. The gearbox is huge, but surprisingly light.




Prep for new engine:
  • Remove clutch.
  • Remove flywheel.
Got the clutch off easy enough, but need a T55 Torx socket to remove the flywheel so that will have to wait until I get it from work tomorrow.



NOTE: Missing bolt from exhaust cross-member.

Monday, 22 September 2014

E60: Engine Swap Week - Day 2

  • Remove headlights and front crash-bar.
  • Remove starter motor.
  • Remove oil filter / cooler.
  • Photograph and disconnect vacuum hoses and wiring-connectors.
  • Attempt remove engine.
  • Remove exhaust-system.
  • Remove heat-shield.
  • Remove gearbox mounts.
  • Remove 2 of 3 prop-shaft bolts [coupling to gearbox].
Sadly, the first attempt did not work. The sump still gets stuck on the sub-frame. TIS says to first remove the prop and gearbox, so it looks like this is the only way.

POA for Day 3:
1. Bolt gearbox mount back up.
2. Loosen remaining prop-shaft bolt.
3. Lift car and put axle-stand under jacking point.
4. Support gearbox and remove mounts.
5. Drop prop-shaft.

NOTE: Cut off rubber exhaust-hanger needs new - Part no. 18207578238

Blue nylon rope not the best for lifting engines, but note a lot of weight is removed from the engine - head, ATF-pump, oil filter-cooler, A/C comp etc.

Sunday, 21 September 2014

E60: Engine Swap Week - Day 1

  • Remove all slam-panel and grilles / trim.
  • Drain and remove radiator.
  • Remove drive-belts.
  • Bleed air-con, remove a/c radiator and compressor.
  • Drain PAS-fluid, remove PAS-pump and cooler.
  • Remove alternator.
  • Remove intercooler.
  • Disconnect and remove injectors / fuel-rail.
  • Disconnect wiring-loom from ECU / relay-box.
NOTE: Broken T-piece on injector leak-off hose needs replacing if doesn't come with engine. [Part no. - 13537789364].



Wednesday, 17 September 2014

E60: 530d Replacement Engine - the time has come!

Im not a fan of engine swaps, they never go perfectly, but with the amount of effort and cost required to fix my original lump, I've decided to bite the bullet and spend the money. After all, I bought the engine-crane... it was as if I knew what was coming.


Here is my new donkey, cheaper than the going rate at £900, but still on the pricey side. Even if I remove my broken engine and put it on a stand to rebuild, the minimum cost will be about £400 for the new piston / timing-case and it will take a lot of evenings work. On top of that, my current engine, the one that was strong as an ox and never had a major problem until that swirl-flap fell in, still has nearly 140k miles under its belt. This new one has just 78k - nothing for one of these, so I guess the extra spend will be worth it and I am absolutely assured that this one has never had swirl-flap damage. It'll arrive on Monday, so it's high-time I booked some holidays from work and fixed the mothership! Oh, and er, continue renovating my new house... Jeez, maybe a month off work would be in order!

Tuesday, 16 September 2014

E46: New secondary air-pump - one last bash...

Thought I would have one ultimate stab at the E46 as it is such a nice car to drive and only let down by shabby bodywork, which I can do something about, and the super low idling problem, which apparently I can't.

I refitted the Vanos-actuator and checked for anything I'd disturbed under the inlet manifold, finding a loose wire connector which I clicked back in, though the CCV was all plumbed up fine. A replacement secondary air-pump and its hose / filter was £30 and the only thing now missing from the inlet arrangement. It took no time to fit, just two 13mm bolts holding it on and swapping the hoses over, but has still, alas, made no difference.



I've spent nearly £300 on parts to cure this engine of its fault, but nothing has done the trick so I guess I will have to call it a day and scrap her after all. Again a shame, as it has 9 months MOT and 4 months tax left on it. The running gear is sound, I sorted the brakes and the engine runs fine when underway, pulling well in all gears over 1500rpm. Handling is as sweet as any E46. The interior and exterior are in terrible nick, but thats nothing that couldn't be sorted with a day or two spent on it. That's only worth doing if the car is useable however, and it sadly isn't.

On top of the impossible low-idling, the handbrake-shoes have collapsed in some way and stick on completely in reverse with the handbrake off. This is probably from being used so much to stop the car while my right foot was still keeping the revs up, but is extra work regardless. A large M12 bolt holding one of the front shock-absorber struts broke while I was attempting to fit the coilovers months ago. I've been driving on it and the strut hasn't moved at all, but it too will need replacing at some point and removing the stud will be interesting. Inside the car, the fan for the heater/blower doesn't work and the driver's door card is missing, meaning no speaker or door handle. Exiting the car with dignity can only be done by lowering the window and reaching out for the other handle, but all these foibles I rather liked. Using it every day was a nightmare though and, with the 5-Series engine swap underway I just won't have the time and money to restore it, so I'm hoping I can get the £200 I paid for it back from a breaker. That means I'm down about £300 on the whole deal. I could make the £500 back and probably more by breaking the car, but I could really do with it out of the way quickly now so a loss it may have to be.

Monday, 15 September 2014

E36 316i Comp: chilling update...

Well, the new head gasket is on and the car is running like a bag of spanners. I think the slapdash chain refitment may have knocked the timing out slightly. I shall have to break out the Gunson timing gun kit I bought for the E21. Oh the joys of £200 Beemers...

The cooling issue appears to be sorted, though with the thermostat removed by the previous owner it's now running a tad on the cool side. I grilled the car the 2 miles to work this morning and could only muster a 1/4 from the temp. gauge. Ah well, a new stat can't be much. 


Sunday, 14 September 2014

E60: Cracked lower timing-case - engine finished.

Yeah well that's torn it. Literally, torn it open. After all that effing about with the sump removal, finding the right piston and drilling off those snapped head bolts, I find a whopping great crack in the lower timing-case!



I wonder what caused this? Vibration from the swirl-flap doing its dance? High crankcase pressure from the dodgy piston? Who knows, but we can safely say that's where the oil leak was coming from!

It's a big enough job as it is to replace that single damaged piston, but to swap the lower timing-case as well involves stripping the entire front of the car, getting all the pulleys off and fully removing the crankshaft. Hmm, a lot of work and a lot more cost, this definitely calls for a replacement engine... Watch this space!!

Wednesday, 10 September 2014

E36 316i Compact: New head-gasket.

Well, it's been a busy month again in Beemer Lab and I've just bought a new house which hasn't helped. Firstly, I finally removed the stuck head-bolts from the E60, got the head off and found where my oil leak is coming from... The lower timing case has a big crack in it! It's too big a job to replace that and do the new piston, so it looks like the 530d does need a new engine after all, what a shame after my £500+ spend.

As there is no E46 progress still, I decided a cheap runaround BMW was needed on a temporary basis so I shelled out a quick £200 on an X-reg E36 316i Compact, again in Titansilver. It has 4 months tax and 10 months MOT so seemed ideal as a stop gap. That was until I went to pick up a fridge and it majorly overheated. After I limped home I found oil in the water, water in the oil and a constant bubbling from the radiator. Blown head gasket then!

I had to use it for 2 weeks in this state, only doing the 2 mile trip to work and no further, but still it was getting to max temp as I pulled up on the drive. The gasket was only £18 off eBay and is FAI. The job only took about 4 hours (oh the joys of working with a single cam!) and it is back on the road and running quite cool so far, though I will need to put it through its paces to find out if it was just a dodgy gasket or if there is a real cooling problem that's caused it.

I will cover the poor E60 and it's future in more detail soon. Oh, and I've also bought a new secondary air-pump or the E46 so watch this space. 3 Beemers and counting...

£18 delivered. eBay FTW still.
By gosh, that looks like some hot oil.
The centre two head-bolts [1 and 2] were finger loose when removed!
This has obviously allowed oil and water to mingle. Blast marks round
the front cylinder show where combustion was stopping water entering the head.
This whole head-gasket swap took about 4 hours, so how
hastily the last one was thrown on is disturbing...
Lots of burnt oil and split gasket over the head, but it cleaned up well.
Think I will leave cleaning the cooling system for another day though. The head is caked with 'rad-weld' type stuff.
Amazingly, after all that overheating, the head is straight as anything! BMW alloy heads are forgiving to say the least.
10 minutes with a razor-blade and the block is good as new. PIston don't look half bad either.
New gasket on. The re-tightening sequence is 30nm, 90 degrees and
another 90 degrees. I wonder if the last guy to work on it only did
the 30nm and forgot about the torque angling?